【CentOS】php53-common conflicts with php-common 的解决办法

    用yum安装php-mysql的时候提示

      --> php53-common conflicts with php-common
    Error: php53-common conflicts with php-common
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.

    使用提示的 --skip-broken 和 package-cleanup 都无效.



    解决办法:

    1. 查看操作系统是32位的还是64位的

    2. 根据系统版本安装从以下位置找到不同的安装包进行安装

    64位:http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/x86_64/

    32位:http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/i386/

    类似如下的命令进行安装

    rpm -Uvh http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/x86_64/epel-release-5-4.noarch.rpm
    rpm -Uvh http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/i386/ius-release-1.0-10.ius.el5.noarch.rpm

    3. 导入GPG Key

    rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
    rpm --import /etc/pki/rpm-gpg/IUS-COMMUNITY-GPG-KEY

    4. 安装yum-plugin-replace

    yum install yum-plugin-replace

    5. 使用php53u安装包替换php53安装包

    yum replace php53 --replace-with php53u

    6. 查看php版本

    [root@04_18 ~]# php -v
    PHP 5.3.23 (cli) (built: Mar 15 2013 10:46:06)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies

    7. 重新安装php-mysql,成功

    搞定



    本博客所有文章如无特别注明均为原创。
    复制或转载请以超链接形式注明转自枫芸志,原文地址《【CentOS】php53-common conflicts with php-common 的解决办法
    标签:
    分享:

还没有人抢沙发呢~

无觅相关文章插件,快速提升流量